Mailster tries to create the screenshots of your template files on the fly on one of our servers. This should happen without any further action but doesn’t in a couple of situations.

When you create a new campaign with a template for the first time you may miss the module screen shots on the right. This can be caused by these reasons:

They weren’t created already.

Mailster creates the screenshots on our server. For technical reasons this is not possible on many shared hosts and require some extensions running on your server. We use node.js to process this in a queue and once they are finished your WordPress site fetches the thumbnails from our server.

Please wait a couple of minutes until they show up.

The option is disabled.

There’s an option on the general tab in the settings to disable module thumbnails. This way no data is sent to our servers and you have no module thumbnails on all your templates.

Enable it on the settings page.

The template file is broken.

If you have some errors in your HTML of your template files our script may not be able to process your modules. This often happens if you miss a closing tag or have not allowed children in table tags.

Fix your template file.

Our servers are not accessible.

Maybe your server doesn’t allow a connection to our thumbnail server.

Please get in touch with your host to get this sorted.

Your License is invalid

Screenshots can only be processed if you provide a valid license.

Register Mailster on the Dashboard.

You’re not using the latest version

Screenshots are only available for the latests version. Find the latest available version on the changelog page.

Update Mailster.

Remove processed screenshots

If you like to remove the thumbnail screenshots (to process them again) go to the wp-content/uploads/mailster/screenshots folder and remove the folder from your template.

The next time you start a new campaign with this template Mailster tries to create your thumbnails again.